# Network failure connecting TagSpaces lite web to s3proxy

**URL:** <https://tagspaces.discourse.group/t/network-failure-connecting-tagspaces-lite-web-to-s3proxy/238>\
**Category:** Help\
**Created:** [December 27, 2023, 7:08pm UTC](https://tagspaces.discourse.group/t/network-failure-connecting-tagspaces-lite-web-to-s3proxy/238 "2023-12-27T19:08:48Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![wisecloud](https://avatars.discourse-cdn.com/v4/letter/w/47e85d/32.png) [@wisecloud](https://tagspaces.discourse.group/u/wisecloud)\
**Post date:** [December 27, 2023, 7:08pm UTC](https://tagspaces.discourse.group/t/network-failure-connecting-tagspaces-lite-web-to-s3proxy/238/1 "2023-12-27T19:08:48Z")

</div>

I deployed tagspaces (192.168.1.3:8181) and s3proxy (192.168.1.3:8080) in podman, but when I try to connect s3proxy from tagspaces using webui i get error “Error loading folder: Network Failure”.  
If I go to s3 bucket I see access denied (expected, but still shows s3 is up and accessible)  
Here is my connection settings:

 ![tagspaces_connection](https://global.discourse-cdn.com/free1/uploads/tagspaces/original/1X/b8029c020881b5f928194e35a0e9da0db7a1172b.png)

---

<div class="post-metadata">

**Author:** ![ilian](https://yyz2.discourse-cdn.com/free1/user_avatar/tagspaces.discourse.group/ilian/32/6_2.png) [@ilian](https://tagspaces.discourse.group/u/ilian)\
**Post date:** [December 28, 2023, 3:14pm UTC](https://tagspaces.discourse.group/t/network-failure-connecting-tagspaces-lite-web-to-s3proxy/238/2 "2023-12-28T15:14:54Z")

</div>

Have you followed the steps in this tutorial?

> **[Exposing local folders as object storage with S3Proxy | TagSpaces Docs](https://docs.tagspaces.org/tutorials/folders-as-objectstorage-with-s3proxy/)**
>
> Introduction

Especially the part with starting the s3proxy docker with the S3PROXY\_CORS\_ALLOW\_ALL=“true” parameter?

---

<div class="post-metadata">

**Author:** ![wisecloud](https://avatars.discourse-cdn.com/v4/letter/w/47e85d/32.png) [@wisecloud](https://tagspaces.discourse.group/u/wisecloud)\
**Post date:** [December 28, 2023, 4:49pm UTC](https://tagspaces.discourse.group/t/network-failure-connecting-tagspaces-lite-web-to-s3proxy/238/3 "2023-12-28T16:49:09Z")

</div>

Yes, I used this exact manual, only edited ports

---

<div class="post-metadata">

**Author:** ![wisecloud](https://avatars.discourse-cdn.com/v4/letter/w/47e85d/32.png) [@wisecloud](https://tagspaces.discourse.group/u/wisecloud)\
**Post date:** [March 3, 2024, 4:47pm UTC](https://tagspaces.discourse.group/t/network-failure-connecting-tagspaces-lite-web-to-s3proxy/238/4 "2024-03-03T16:47:00Z")

</div>

I managed to make it work with docker

---

<div class="post-metadata">

**Author:** ![luhrMan](https://yyz2.discourse-cdn.com/free1/user_avatar/tagspaces.discourse.group/luhrman/32/125_2.png) [@luhrMan](https://tagspaces.discourse.group/u/luhrMan)\
**Post date:** [March 8, 2024, 10:14am UTC](https://tagspaces.discourse.group/t/network-failure-connecting-tagspaces-lite-web-to-s3proxy/238/5 "2024-03-08T10:14:40Z")

</div>

Please, explain! I am attempting with docker and when I put in the s3proxy info into the Tagspaces web page (run via docker) it will say “Connected to Object Storage” but I will not be able to view files. They are both on the same docker network

---

<div class="post-metadata">

**Author:** ![wisecloud](https://avatars.discourse-cdn.com/v4/letter/w/47e85d/32.png) [@wisecloud](https://tagspaces.discourse.group/u/wisecloud)\
**Post date:** [March 9, 2024, 9:37am UTC](https://tagspaces.discourse.group/t/network-failure-connecting-tagspaces-lite-web-to-s3proxy/238/6 "2024-03-09T09:37:50Z")

</div>

I bypassed it exposing s3proxy port, not using docker network IP. Like so:

tagspaces: [http://192.168.1.3:5000](http://192.168.1.3:5000)  
s3proxy: [http://192.168.1.3:9000](http://192.168.1.3:9000)

Using docker network IP dont work in my case too

---

<div class="post-metadata">

**Author:** ![ilian](https://yyz2.discourse-cdn.com/free1/user_avatar/tagspaces.discourse.group/ilian/32/6_2.png) [@ilian](https://tagspaces.discourse.group/u/ilian)\
**Post date:** [March 25, 2024, 3:15pm UTC](https://tagspaces.discourse.group/t/network-failure-connecting-tagspaces-lite-web-to-s3proxy/238/7 "2024-03-25T15:15:22Z")

</div>

A network error can occur when you try to connect s3proxy running without SSL certificate, from TagSpaces Web with SSL certificate.

 ![image](https://global.discourse-cdn.com/free1/uploads/tagspaces/original/1X/4ec20a1b33ec5e7e8548e4114d87af7f347bdb91.png)
